<!DOCTYPE html>
      <html lang="en">
        <head>
          <title>Fantasy Football News, Advice, Stats, Projections & Draft Kit</title>
          <meta name="viewport" content="width=device-width, initial-scale=1.0" />
          <meta name="google-site-verification" content="XvJCkUmDA4DN_BrGsmMcrndCPfFs0fAlOElDTIVvL3k" />
          <script src="https://js.stripe.com/v3/"></script>
          <script type="text/javascript">
            window.gciAnalyticsUAID = 'SMG-TEALIUM-THEHUDDLE';
            var gciAnalytics_data = {
              'event-type': 'pageview',
              'content-ssts-section':'sports',
              'content-ssts-subsection':'sports:thehuddle',
              'page-blogname':'thehuddle',
              'page-has-video': 'no',
              'content-type':'other smg',
              'page-domain':'tools.thehuddle.com',
            };
          </script>
          <script type="text/javascript" src="https://www.gannett-cdn.com/dcjs/prod/main.js"></script>
          <link rel="apple-touch-icon" sizes="57x57" href="https://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=57">
          <link rel="apple-touch-icon" sizes="60x60" href="https://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=60">
          <link rel="apple-touch-icon" sizes="72x72" href="https://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=72">
          <link rel="apple-touch-icon" sizes="76x76" href="https://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=76">
          <link rel="apple-touch-icon" sizes="114x114" href="https://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=114">
          <link rel="apple-touch-icon" sizes="120x120" href="https://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=120">
          <link rel="apple-touch-icon" sizes="144x144" href="https://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=144">
          <link rel="apple-touch-icon" sizes="152x152" href="https://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=152">
          <link rel="apple-touch-icon" sizes="180x180" href="https://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=180">
          <link rel="icon" type="image/png" sizes="192x192"  href="https://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=192">
          <link rel="icon" type="image/png" sizes="32x32" href="https://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=32">
          <link rel="icon" type="image/png" sizes="96x96" href="https://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=96">
          <link rel="icon" type="image/png" sizes="16x16" href="https://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=16">
          <meta name="msapplication-TileColor" content="#ffffff">
          <meta name="msapplication-TileImage" content="https://1.gravatar.com/blavatar/512d196445bae0a829c1ab186c66e2f2?s=144">
          <meta name="theme-color" content="#ffffff">
          <link rel='stylesheet' href='/static/stylesheets/main-less.css' />
<link rel='stylesheet' href='/static/stylesheets/main-vendors.css' />
<link rel='stylesheet' href='/static/stylesheets/main-app.css' />
<link rel='stylesheet' href='/static/stylesheets/main.d0ac3f7d409591d7c86912cc98c2f754.css' />
<link rel='stylesheet' href='/static/stylesheets/Layout.1c18b151097dde2a505275d23dd1c719.css' />
<link rel='stylesheet' href='/static/stylesheets/News.fe9d51a926ed47c53c47d3dc4837a638.css' />
        </head>
        <body>
          <noscript>
            <div style="font-family: sans-serif; position: relative; z-index: 5050; text-align: center; font-weight: bold; font-size: 120%; color: #FFF; background-color: #AE0000; padding: 5px 0;">
              <p style="color: white;">Make sure you have JavaScript enabled in your browser settings. The Huddle requires JavaScript in order to be fully functional.<br>
              Contact us at <a href="mailto:support@thehuddle.com" style="color:yellow; text-decoration: underline;">support@thehuddle.com</a> with any questions.
            </div>
          </noscript>
          <div id="root"><div class="App__body--2nH88" data-reactroot="" data-reactid="1" data-react-checksum="1413229733"><div class="DesktopLayout__layout--2272R" data-reactid="2"><div class="ui secondary desktopHeader__menu--2VZ_v menu" data-reactid="3"><div data-reactid="4"><a href="http://thehuddle.com" data-reactid="5"><div data-reactid="6"><img class="ui image desktopHeader__huddleLogo--uSZ1e" src="data:image/svg+xml;base64,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" data-reactid="7"/></div></a><div class="desktopHeader__orangeLogoUnderline--3sWJT" data-reactid="8"></div></div><div class="right menu" data-reactid="9"><a style="font-family:Helvetica;font-size:11px;font-weight:bold;line-height:1.36;color:#015d03;padding-left:5px;padding-right:5px;" class="link item greenHighlightedMenuButton" data-reactid="10">SUBSCRIBE</a><span style="width:2px;height:24px;border:solid 1px #cccccc;margin:18px 5px 0px 5px;" data-reactid="11"></span><a style="font-family:Helvetica;font-size:11px;font-weight:bold;line-height:1.36;color:#015d03;padding-left:5px;padding-right:5px;" class="link item" data-reactid="12">SIGN IN</a><span style="width:2px;height:24px;border:solid 1px #cccccc;margin:18px 5px 0px 5px;" data-reactid="13"></span><a href="https://thehuddle.com/help-with-the-huddle-site/" style="font-family:Helvetica;font-size:11px;font-weight:bold;line-height:1.36;color:#015d03;padding-left:5px;padding-right:5px;" class="link item" data-reactid="14">HELP</a></div><div data-reactid="15"><a class="ui image desktopHeader__usaTodayLogo--Cgiz8" href="https://www.usatoday.com/sports/" data-reactid="16"><img alt="logo" src="data:image/svg+xml;base64,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" data-reactid="17"/></a></div></div><div class="ui large inverted attached desktopNav__primaryNav--3F-Bq menu" data-reactid="18"><div role="listbox" aria-expanded="false" class="ui item simple dropdown desktopNav__menuButtonStyle--yxXnU" tabindex="0" data-reactid="19"><a href="https://thehuddle.com/2021-fantasy-football-draft-guide/" style="color:inherit;" data-reactid="20"><!-- react-text: 21 -->Draft Guide<!-- /react-text --><img src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMiIgaGVpZ2h0PSI4IiB2aWV3Qm94PSIwIDAgMTIgOCI+CiAgICA8cGF0aCBmaWxsPSIjRDkzIiBmaWxsLXJ1bGU9ImV2ZW5vZGQiIGQ9Ik0xMC4xNDcgMEw1LjkxOSA0LjMxIDEuNzcyLjA3OCAwIDEuODg5IDUuOTk0IDggMTIgMS44OXoiLz4KPC9zdmc+Cg==" alt="" class="desktopNav__arrowIcon--332nA" data-reactid="22"/></a><div class="menu transition desktopNav__dropDownMenuStyle--3FP3L" data-reactid="23"><a href="/cheatsheets" class="desktopNav__dropdownItem--17tqO" aria-current="false" data-reactid="24"><span data-reactid="25">Cheat Sheets</span><img src="data:image/svg+xml;base64,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" alt="Restricted access" data-reactid="26"/></a><a href="/fantasy-football-projections" class="desktopNav__dropdownItem--17tqO" aria-current="false" data-reactid="27"><span data-reactid="28">Rankings / Projections</span><img src="data:image/svg+xml;base64,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" alt="Restricted access" data-reactid="29"/></a><a href="http://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/top-200-standard" class="desktopNav__dropdownItem--17tqO" data-reactid="30"><span data-reactid="31">Top 200 Overall</span></a><a href="http://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/top-200-ppr" class="desktopNav__dropdownItem--17tqO" data-reactid="32"><span data-reactid="33">Top 200 PPR</span></a><a href="http://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/top-200-qb-heavy" class="desktopNav__dropdownItem--17tqO" data-reactid="34"><span data-reactid="35">Top 200 QB Heavy</span></a><a href="http://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/auction-10-team" class="desktopNav__dropdownItem--17tqO" data-reactid="36"><span data-reactid="37">10-Team Auction Cheat Sheet</span></a><a href="http://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/auction-12-team" class="desktopNav__dropdownItem--17tqO" data-reactid="38"><span data-reactid="39">12-Team Auction Cheat Sheet</span></a><a href="http://tools.thehuddle.com/fantasy-football-rankings-cheat-sheets/2021/dynasty" class="desktopNav__dropdownItem--17tqO" data-reactid="40"><span data-reactid="41">Keeper/Dynasty Cheat Sheet</span></a></div></div><div role="listbox" aria-expanded="false" class="ui item simple dropdown desktopNav__menuButtonStyle--yxXnU" tabindex="0" data-reactid="42"><a href="https://thehuddle.com/in-season-fantasy-football/" style="color:inherit;" data-reactid="43"><!-- react-text: 44 -->Inseason<!-- /react-text --><img src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMiIgaGVpZ2h0PSI4IiB2aWV3Qm94PSIwIDAgMTIgOCI+CiAgICA8cGF0aCBmaWxsPSIjRDkzIiBmaWxsLXJ1bGU9ImV2ZW5vZGQiIGQ9Ik0xMC4xNDcgMEw1LjkxOSA0LjMxIDEuNzcyLjA3OCAwIDEuODg5IDUuOTk0IDggMTIgMS44OXoiLz4KPC9zdmc+Cg==" alt="" class="desktopNav__arrowIcon--332nA" data-reactid="45"/></a><div class="menu transition desktopNav__dropDownMenuStyle--3FP3L" data-reactid="46"><a href="http://tools.thehuddle.com/fantasy-football-projections" class="desktopNav__dropdownItem--17tqO" data-reactid="47"><span data-reactid="48">Fantasy Football Projections</span></a><a href="http://tools.thehuddle.com/cheatsheets" class="desktopNav__dropdownItem--17tqO" data-reactid="49"><span data-reactid="50">Fantasy Football Cheat Sheets</span></a><a href="https://thehuddle.com/dfs-playbook-daily-fantasy-football-picks/" class="desktopNav__dropdownItem--17tqO" data-reactid="51"><span data-reactid="52">DFS - Daily Fantasy Football</span></a><a href="http://tools.thehuddle.com/in-season/nfl-fantasy-football-game-predictions" class="desktopNav__dropdownItem--17tqO" data-reactid="53"><span data-reactid="54">NFL Game Predictions and Picks</span></a><a href="http://tools.thehuddle.com/in-season/fantasy-football-start-bench-list" class="desktopNav__dropdownItem--17tqO" data-reactid="55"><span data-reactid="56">Fantasy Football Start/Bench Tool</span></a><a href="https://thehuddle.com/2020/05/07/2020-nfl-schedule-team-by-week-grid/" class="desktopNav__dropdownItem--17tqO" data-reactid="57"><span data-reactid="58">NFL Schedule Grid</span></a><a href="http://thehuddle.com/in-season-fantasy-football/" class="desktopNav__dropdownItem--17tqO" data-reactid="59"><span data-reactid="60">All Tools and Articles (by day)</span></a></div></div><div class="link item desktopNav__menuButtonStyle--yxXnU" data-reactid="61"><a href="https://tools.thehuddle.com/nfl-fantasy-football-player-news/" style="color:inherit;" data-reactid="62">News</a></div><div role="listbox" aria-expanded="false" class="ui item simple dropdown desktopNav__menuButtonStyle--yxXnU" tabindex="0" data-reactid="63"><a href="http://thehuddle.com/fantasy-football-statistics/" style="color:inherit;" data-reactid="64"><!-- react-text: 65 -->Stats<!-- /react-text --><img src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMiIgaGVpZ2h0PSI4IiB2aWV3Qm94PSIwIDAgMTIgOCI+CiAgICA8cGF0aCBmaWxsPSIjRDkzIiBmaWxsLXJ1bGU9ImV2ZW5vZGQiIGQ9Ik0xMC4xNDcgMEw1LjkxOSA0LjMxIDEuNzcyLjA3OCAwIDEuODg5IDUuOTk0IDggMTIgMS44OXoiLz4KPC9zdmc+Cg==" alt="" class="desktopNav__arrowIcon--332nA" data-reactid="66"/></a><div class="menu transition desktopNav__dropDownMenuStyle--3FP3L" data-reactid="67"><a href="http://tools.thehuddle.com/season" class="desktopNav__dropdownItem--17tqO" data-reactid="68"><span data-reactid="69">Stats: Season-to-Date (by position)</span></a><a href="http://tools.thehuddle.com/weekly" class="desktopNav__dropdownItem--17tqO" data-reactid="70"><span data-reactid="71">Stats: Weekly (by position)</span></a><a href="http://tools.thehuddle.com/stats/box-scores" class="desktopNav__dropdownItem--17tqO" data-reactid="72"><span data-reactid="73">Fantasy Football Box Scores</span></a><a href="http://tools.thehuddle.com/stats/strength-of-schedule" class="desktopNav__dropdownItem--17tqO" data-reactid="74"><span data-reactid="75">Strength of Schedule Tool</span></a><a href="http://tools.thehuddle.com/stats/team_position_rankings" class="desktopNav__dropdownItem--17tqO" data-reactid="76"><span data-reactid="77">Team Position Rankings</span></a><a href="http://tools.thehuddle.com/stats/team-position-rank-matchups" class="desktopNav__dropdownItem--17tqO" data-reactid="78"><span data-reactid="79">Team Position Rank Matchups</span></a><a href="http://tools.thehuddle.com/stats/game-stat-matchups" class="desktopNav__dropdownItem--17tqO" data-reactid="80"><span data-reactid="81">Game Statistics Matchups</span></a></div></div><div role="listbox" aria-expanded="false" class="ui item simple dropdown desktopNav__menuButtonStyle--yxXnU" tabindex="0" data-reactid="82"><a href="/teams" style="color:inherit;" data-reactid="83"><!-- react-text: 84 -->Teams<!-- /react-text --><img src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMiIgaGVpZ2h0PSI4IiB2aWV3Qm94PSIwIDAgMTIgOCI+CiAgICA8cGF0aCBmaWxsPSIjRDkzIiBmaWxsLXJ1bGU9ImV2ZW5vZGQiIGQ9Ik0xMC4xNDcgMEw1LjkxOSA0LjMxIDEuNzcyLjA3OCAwIDEuODg5IDUuOTk0IDggMTIgMS44OXoiLz4KPC9zdmc+Cg==" alt="" class="desktopNav__arrowIcon--332nA" data-reactid="85"/></a><div style="left:-334px;" class="menu transition" data-reactid="86"><div class="teams" style="display:flex;width:100%;" data-reactid="87"><span class="desktopNav__teamsColumn--1tvxk" data-reactid="88"><div data-reactid="89"><div class="desktopNav__teamsDivisionName--2nTLA" data-reactid="90">AFC East</div><a href="/nfl-team/1/new-england-patriots" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="91"><!-- react-text: 92 -->New England<!-- /react-text --><!-- react-text: 93 --> <!-- /react-text --><!-- react-text: 94 -->Patriots<!-- /react-text --></a><a href="/nfl-team/7/miami-dolphins" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="95"><!-- react-text: 96 -->Miami<!-- /react-text --><!-- react-text: 97 --> <!-- /react-text --><!-- react-text: 98 -->Dolphins<!-- /react-text --></a><a href="/nfl-team/22/new-york-jets" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="99"><!-- react-text: 100 -->New York<!-- /react-text --><!-- react-text: 101 --> <!-- /react-text --><!-- react-text: 102 -->Jets<!-- /react-text --></a><a href="/nfl-team/25/buffalo-bills" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="103"><!-- react-text: 104 -->Buffalo<!-- /react-text --><!-- react-text: 105 --> <!-- /react-text --><!-- react-text: 106 -->Bills<!-- /react-text --></a></div><div data-reactid="107"><div class="desktopNav__teamsDivisionName--2nTLA" data-reactid="108">AFC North</div><a href="/nfl-team/18/pittsburgh-steelers" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="109"><!-- react-text: 110 -->Pittsburgh<!-- /react-text --><!-- react-text: 111 --> <!-- /react-text --><!-- react-text: 112 -->Steelers<!-- /react-text --></a><a href="/nfl-team/23/cincinnati-bengals" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="113"><!-- react-text: 114 -->Cincinnati<!-- /react-text --><!-- react-text: 115 --> <!-- /react-text --><!-- react-text: 116 -->Bengals<!-- /react-text --></a><a href="/nfl-team/24/baltimore-ravens" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="117"><!-- react-text: 118 -->Baltimore<!-- /react-text --><!-- react-text: 119 --> <!-- /react-text --><!-- react-text: 120 -->Ravens<!-- /react-text --></a><a href="/nfl-team/29/cleveland-browns" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="121"><!-- react-text: 122 -->Cleveland<!-- /react-text --><!-- react-text: 123 --> <!-- /react-text --><!-- react-text: 124 -->Browns<!-- /react-text --></a></div></span><span class="desktopNav__teamsColumn--1tvxk" data-reactid="125"><div data-reactid="126"><div class="desktopNav__teamsDivisionName--2nTLA" data-reactid="127">AFC South</div><a href="/nfl-team/11/houston-texans" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="128"><!-- react-text: 129 -->Houston<!-- /react-text --><!-- react-text: 130 --> <!-- /react-text --><!-- react-text: 131 -->Texans<!-- /react-text --></a><a href="/nfl-team/13/jacksonville-jaguars" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="132"><!-- react-text: 133 -->Jacksonville<!-- /react-text --><!-- react-text: 134 --> <!-- /react-text --><!-- react-text: 135 -->Jaguars<!-- /react-text --></a><a href="/nfl-team/19/indianapolis-colts" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="136"><!-- react-text: 137 -->Indianapolis<!-- /react-text --><!-- react-text: 138 --> <!-- /react-text --><!-- react-text: 139 -->Colts<!-- /react-text --></a><a href="/nfl-team/30/tennessee-titans" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="140"><!-- react-text: 141 -->Tennessee<!-- /react-text --><!-- react-text: 142 --> <!-- /react-text --><!-- react-text: 143 -->Titans<!-- /react-text --></a></div><div data-reactid="144"><div class="desktopNav__teamsDivisionName--2nTLA" data-reactid="145">AFC West</div><a href="/nfl-team/3/los-angeles-chargers" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="146"><!-- react-text: 147 -->Los Angeles<!-- /react-text --><!-- react-text: 148 --> <!-- /react-text --><!-- react-text: 149 -->Chargers<!-- /react-text --></a><a href="/nfl-team/8/denver-broncos" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="150"><!-- react-text: 151 -->Denver<!-- /react-text --><!-- react-text: 152 --> <!-- /react-text --><!-- react-text: 153 -->Broncos<!-- /react-text --></a><a href="/nfl-team/10/las-vegas-raiders" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="154"><!-- react-text: 155 -->Las Vegas<!-- /react-text --><!-- react-text: 156 --> <!-- /react-text --><!-- react-text: 157 -->Raiders<!-- /react-text --></a><a href="/nfl-team/31/kansas-city-chiefs" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="158"><!-- react-text: 159 -->Kansas City<!-- /react-text --><!-- react-text: 160 --> <!-- /react-text --><!-- react-text: 161 -->Chiefs<!-- /react-text --></a></div></span><span class="desktopNav__teamsColumn--1tvxk" data-reactid="162"><div data-reactid="163"><div class="desktopNav__teamsDivisionName--2nTLA" data-reactid="164">NFC East</div><a href="/nfl-team/4/washington-football-team" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="165"><!-- react-text: 166 -->Washington<!-- /react-text --><!-- react-text: 167 --> <!-- /react-text --><!-- react-text: 168 -->Football Team<!-- /react-text --></a><a href="/nfl-team/6/dallas-cowboys" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="169"><!-- react-text: 170 -->Dallas<!-- /react-text --><!-- react-text: 171 --> <!-- /react-text --><!-- react-text: 172 -->Cowboys<!-- /react-text --></a><a href="/nfl-team/17/new-york-giants" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="173"><!-- react-text: 174 -->New York<!-- /react-text --><!-- react-text: 175 --> <!-- /react-text --><!-- react-text: 176 -->Giants<!-- /react-text --></a><a href="/nfl-team/28/philadelphia-eagles" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="177"><!-- react-text: 178 -->Philadelphia<!-- /react-text --><!-- react-text: 179 --> <!-- /react-text --><!-- react-text: 180 -->Eagles<!-- /react-text --></a></div><div data-reactid="181"><div class="desktopNav__teamsDivisionName--2nTLA" data-reactid="182">NFC North</div><a href="/nfl-team/2/detroit-lions" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="183"><!-- react-text: 184 -->Detroit<!-- /react-text --><!-- react-text: 185 --> <!-- /react-text --><!-- react-text: 186 -->Lions<!-- /react-text --></a><a href="/nfl-team/14/green-bay-packers" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="187"><!-- react-text: 188 -->Green Bay<!-- /react-text --><!-- react-text: 189 --> <!-- /react-text --><!-- react-text: 190 -->Packers<!-- /react-text --></a><a href="/nfl-team/16/minnesota-vikings" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="191"><!-- react-text: 192 -->Minnesota<!-- /react-text --><!-- react-text: 193 --> <!-- /react-text --><!-- react-text: 194 -->Vikings<!-- /react-text --></a><a href="/nfl-team/27/chicago-bears" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="195"><!-- react-text: 196 -->Chicago<!-- /react-text --><!-- react-text: 197 --> <!-- /react-text --><!-- react-text: 198 -->Bears<!-- /react-text --></a></div></span><span class="desktopNav__teamsColumn--1tvxk" data-reactid="199"><div data-reactid="200"><div class="desktopNav__teamsDivisionName--2nTLA" data-reactid="201">NFC South</div><a href="/nfl-team/5/new-orleans-saints" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="202"><!-- react-text: 203 -->New Orleans<!-- /react-text --><!-- react-text: 204 --> <!-- /react-text --><!-- react-text: 205 -->Saints<!-- /react-text --></a><a href="/nfl-team/12/atlanta-falcons" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="206"><!-- react-text: 207 -->Atlanta<!-- /react-text --><!-- react-text: 208 --> <!-- /react-text --><!-- react-text: 209 -->Falcons<!-- /react-text --></a><a href="/nfl-team/15/carolina-panthers" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="210"><!-- react-text: 211 -->Carolina<!-- /react-text --><!-- react-text: 212 --> <!-- /react-text --><!-- react-text: 213 -->Panthers<!-- /react-text --></a><a href="/nfl-team/20/tampa-bay-buccaneers" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="214"><!-- react-text: 215 -->Tampa Bay<!-- /react-text --><!-- react-text: 216 --> <!-- /react-text --><!-- react-text: 217 -->Buccaneers<!-- /react-text --></a></div><div data-reactid="218"><div class="desktopNav__teamsDivisionName--2nTLA" data-reactid="219">NFC West</div><a href="/nfl-team/9/los-angeles-rams" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="220"><!-- react-text: 221 -->Los Angeles<!-- /react-text --><!-- react-text: 222 --> <!-- /react-text --><!-- react-text: 223 -->Rams<!-- /react-text --></a><a href="/nfl-team/21/seattle-seahawks" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="224"><!-- react-text: 225 -->Seattle<!-- /react-text --><!-- react-text: 226 --> <!-- /react-text --><!-- react-text: 227 -->Seahawks<!-- /react-text --></a><a href="/nfl-team/26/arizona-cardinals" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="228"><!-- react-text: 229 -->Arizona<!-- /react-text --><!-- react-text: 230 --> <!-- /react-text --><!-- react-text: 231 -->Cardinals<!-- /react-text --></a><a href="/nfl-team/32/san-francisco-49ers" class="desktopNav__teamNameLink--LtXAX" aria-current="false" data-reactid="232"><!-- react-text: 233 -->San Francisco<!-- /react-text --><!-- react-text: 234 --> <!-- /react-text --><!-- react-text: 235 -->49ers<!-- /react-text --></a></div></span></div></div></div><div class="link item desktopNav__menuButtonStyle--yxXnU" data-reactid="236"><a href="/playerLanding" style="color:inherit;" aria-current="false" data-reactid="237">Players</a></div><div role="listbox" aria-expanded="false" class="ui item simple dropdown desktopNav__menuButtonStyle--yxXnU" tabindex="0" data-reactid="238"><a href="#" style="color:inherit;" data-reactid="239"><!-- react-text: 240 -->More<!-- /react-text --><img src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMiIgaGVpZ2h0PSI4IiB2aWV3Qm94PSIwIDAgMTIgOCI+CiAgICA8cGF0aCBmaWxsPSIjRDkzIiBmaWxsLXJ1bGU9ImV2ZW5vZGQiIGQ9Ik0xMC4xNDcgMEw1LjkxOSA0LjMxIDEuNzcyLjA3OCAwIDEuODg5IDUuOTk0IDggMTIgMS44OXoiLz4KPC9zdmc+Cg==" alt="" class="desktopNav__arrowIcon--332nA" data-reactid="241"/></a><div class="menu transition desktopNav__dropDownMenuStyle--3FP3L" data-reactid="242"><a href="https://tools.thehuddle.com/nfl-depth-charts" class="desktopNav__dropdownItem--17tqO" data-reactid="243"><span data-reactid="244">Fantasy Football NFL Depth Charts</span></a><a href="http://forums.thehuddle.com/" class="desktopNav__dropdownItem--17tqO" data-reactid="245"><span data-reactid="246">Forums</span></a><a href="https://thehuddle.com/2020/04/25/2020-nfl-draft-results-by-round/" class="desktopNav__dropdownItem--17tqO" data-reactid="247"><span data-reactid="248">2020 NFL Draft results</span></a><a href="https://sportsbookwire.usatoday.com/category/nfl-odds-lines-spreads-picks-predictions/" class="desktopNav__dropdownItem--17tqO" data-reactid="249"><span data-reactid="250">NFL betting picks and tips</span></a><a href="http://thehuddle.com/about/" class="desktopNav__dropdownItem--17tqO" data-reactid="251"><span data-reactid="252">About</span></a></div></div><div class="right menu" data-reactid="253"><div class="link item desktopNav__icon--2_wwW" data-reactid="254"><a target="_blank" class="ui inline image" href="https://www.facebook.com/thehuddle" data-reactid="255"><img src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIyNCIgaGVpZ2h0PSIyNCIgdmlld0JveD0iMCAwIDI0IDI0Ij4KICAgIDxwYXRoIGZpbGw9IiNFRUUiIGZpbGwtcnVsZT0iZXZlbm9kZCIgZD0iTTIyLjY2NiAwSDEuMzI0Qy41OTMgMCAwIC41OTMgMCAxLjMyNHYyMS4zNDJjMCAuNzMyLjU5MyAxLjMyNSAxLjMyNCAxLjMyNWgxMS40OVYxNC43SDkuNjg4di0zLjYyMmgzLjEyNlY4LjQxYzAtMy4wOTggMS44OTMtNC43ODYgNC42NTctNC43ODYgMS4zMjQgMCAyLjQ2Mi4wOTkgMi43OTQuMTQzdjMuMjM4bC0xLjkxOC4wMDFjLTEuNTAzIDAtMS43OTQuNzE1LTEuNzk0IDEuNzYzdjIuMzExaDMuNTg1bC0uNDY3IDMuNjIxaC0zLjExOHY5LjI5aDYuMTEzYy43MzEgMCAxLjMyNC0uNTkyIDEuMzI0LTEuMzI0VjEuMzI0QzIzLjk5LjU5MyAyMy4zOTcgMCAyMi42NjYgMCIvPgo8L3N2Zz4K" data-reactid="256"/></a></div><div class="link item desktopNav__icon--2_wwW" data-reactid="257"><a target="_blank" class="ui inline image" href="https://www.twitter.com/TheHuddle" data-reactid="258"><img src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIyNCIgaGVpZ2h0PSIyMCIgdmlld0JveD0iMCAwIDI0IDIwIj4KICAgIDxwYXRoIGZpbGw9IiNFRUUiIGZpbGwtcnVsZT0iZXZlbm9kZCIgZD0iTTI0IDIuMzA5YTkuODQzIDkuODQzIDAgMCAxLTIuODI4Ljc3NUE0Ljk0IDQuOTQgMCAwIDAgMjMuMzM3LjM2YTkuODYgOS44NiAwIDAgMS0zLjEyNyAxLjE5NSA0LjkyNCA0LjkyNCAwIDAgMC04LjM5IDQuNDkxQTEzLjk3OSAxMy45NzkgMCAwIDEgMS42Ny45YTQuOSA0LjkgMCAwIDAtLjY2NiAyLjQ3NmMwIDEuNzA4Ljg3IDMuMjE1IDIuMTkgNC4wOThhNC45MDQgNC45MDQgMCAwIDEtMi4yMy0uNjE2di4wNjJhNC45MjcgNC45MjcgMCAwIDAgMy45NSA0LjgyOCA0LjkzNCA0LjkzNCAwIDAgMS0yLjIyNC4wODUgNC45MjkgNC45MjkgMCAwIDAgNC42IDMuNDE5IDkuODc5IDkuODc5IDAgMCAxLTYuMTE1IDIuMTA4Yy0uMzk4IDAtLjc5LS4wMjQtMS4xNzUtLjA3YTEzLjkzNiAxMy45MzYgMCAwIDAgNy41NDggMi4yMTNjOS4wNTcgMCAxNC4wMS03LjUwMyAxNC4wMS0xNC4wMSAwLS4yMTMtLjAwNi0uNDI1LS4wMTUtLjYzNkExMC4wMDIgMTAuMDAyIDAgMCAwIDI0IDIuMzA4Ii8+Cjwvc3ZnPgo=" data-reactid="259"/></a></div><div class="link item desktopNav__icon--2_wwW" data-reactid="260"><a target="_blank" class="ui inline image" href="http://thehuddle.com/category/podcast/" data-reactid="261"><img src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNiIgaGVpZ2h0PSIyNCIgdmlld0JveD0iMCAwIDE2IDI0Ij4KICAgIDxwYXRoIGZpbGw9IiNEOTMiIGZpbGwtcnVsZT0iZXZlbm9kZCIgZD0iTTE0IDZjMCA3LTIuMSAxMC02IDEwLTMuOTEgMC02LTItNi0xMEgwYzAgOSAzIDEyIDcgMTJ2NC4wMWMtMy4zOS4wNy02IC40OS02IC45OSAwIC41NSAzLjEzIDEgNyAxczctLjQ1IDctMWMwLS41LTIuNjEtLjkyLTYtLjk5VjE4YzMgMCA3LTMgNy0xMmgtMnptLTYgOGMyLjQ5IDAgNC0xLjk3IDQtNUg4VjhoNFY3SDhWNmg0VjVIOFY0aDMuOTRDMTEuNjMgMS41NSAxMC4yIDAgOCAwIDUuNTEgMCA0IDEuOTcgNCA1djRjMCAzLjAzIDEuNTEgNSA0IDV6Ii8+Cjwvc3ZnPgo=" data-reactid="262"/></a></div></div></div><img style="display:block;width:100%;height:5px;opacity:0.08;background-repeat:no-repeat;content:;" src="data:image/svg+xml;base64,PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0idXRmLTgiPz4NCjwhLS0gR2VuZXJhdG9yOiBBZG9iZSBJbGx1c3RyYXRvciAxNy4wLjAsIFNWRyBFeHBvcnQgUGx1Zy1JbiAuIFNWRyBWZXJzaW9uOiA2LjAwIEJ1aWxkIDApICAtLT4NCjwhRE9DVFlQRSBzdmcgUFVCTElDICItLy9XM0MvL0RURCBTVkcgMS4xLy9FTiIgImh0dHA6Ly93d3cudzMub3JnL0dyYXBoaWNzL1NWRy8xLjEvRFREL3N2ZzExLmR0ZCI+DQo8c3ZnIHZlcnNpb249IjEuMSIgaWQ9IkxheWVyXzEiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgeG1sbnM6eGxpbms9Imh0dHA6Ly93d3cudzMub3JnLzE5OTkveGxpbmsiIHg9IjBweCIgeT0iMHB4Ig0KCSB3aWR0aD0iMTAwMHB4IiBoZWlnaHQ9IjVweCIgdmlld0JveD0iMCAwIDEwMDAgNSIgZW5hYmxlLWJhY2tncm91bmQ9Im5ldyAwIDAgMTAwMCA1IiB4bWw6c3BhY2U9InByZXNlcnZlIiBwcmVzZXJ2ZUFzcGVjdFJhdGlvPSJub25lIj4NCjxwYXRoIGZpbGwtcnVsZT0iZXZlbm9kZCIgY2xpcC1ydWxlPSJldmVub2RkIiBkPSJNMCwwaDEwMDB2NWMwLDAtMjU1LjY2NC00LTUwMC41MzMtNEMyNDQuNTM5LDEsMCw1LDAsNVYweiIvPg0KPC9zdmc+DQo=" data-reactid="263"/><div class="ui borderless secondary bottom attached desktopNav__quickLinksMenu--1UvfQ menu" data-reactid="264"><div class="header item desktopNav__menuLabel--1V0fY" data-reactid="265">Quick Links</div><a href="https://tools.thehuddle.com/in-season/nfl-fantasy-football-game-predictions" class="desktopNav__linkText--3-WB5" data-reactid="266">Game Predictions</a><a href="https://tools.thehuddle.com/fantasy-football-projections" class="desktopNav__linkText--3-WB5" data-reactid="267">Player Rankings / Projections</a><a href="https://tools.thehuddle.com/in-season/fantasy-football-start-bench-list" class="desktopNav__linkText--3-WB5" data-reactid="268">Start/Bench Tool</a><a href="https://tools.thehuddle.com/cheatsheets" class="desktopNav__linkText--3-WB5" data-reactid="269">Cheat Sheets</a><a href="https://tools.thehuddle.com/nfl-depth-charts" class="desktopNav__linkText--3-WB5" data-reactid="270">Depth Charts</a></div><div data-reactid="271"><div data-reactid="272">Loading...</div></div><div data-reactid="273"><div style="height:50px;border:0px;margin:0px 0px;padding-left:0px;position:relative;" class="ui basic segment" data-reactid="274"><div style="margin-left:20px;font-family:FuturaTodayBold;font-size:21px;color:#333333;" data-reactid="275">REAL TALK</div><div style="width:147px;height:5px;background-color:#dd9933;position:absolute;bottom:0px;left:0px;" data-reactid="276"></div></div><img style="display:block;width:100%;height:5px;opacity:0.08;background-repeat:no-repeat;content:;" src="data:image/svg+xml;base64,PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0idXRmLTgiPz4NCjwhLS0gR2VuZXJhdG9yOiBBZG9iZSBJbGx1c3RyYXRvciAxNy4wLjAsIFNWRyBFeHBvcnQgUGx1Zy1JbiAuIFNWRyBWZXJzaW9uOiA2LjAwIEJ1aWxkIDApICAtLT4NCjwhRE9DVFlQRSBzdmcgUFVCTElDICItLy9XM0MvL0RURCBTVkcgMS4xLy9FTiIgImh0dHA6Ly93d3cudzMub3JnL0dyYXBoaWNzL1NWRy8xLjEvRFREL3N2ZzExLmR0ZCI+DQo8c3ZnIHZlcnNpb249IjEuMSIgaWQ9IkxheWVyXzEiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgeG1sbnM6eGxpbms9Imh0dHA6Ly93d3cudzMub3JnLzE5OTkveGxpbmsiIHg9IjBweCIgeT0iMHB4Ig0KCSB3aWR0aD0iMTAwMHB4IiBoZWlnaHQ9IjVweCIgdmlld0JveD0iMCAwIDEwMDAgNSIgZW5hYmxlLWJhY2tncm91bmQ9Im5ldyAwIDAgMTAwMCA1IiB4bWw6c3BhY2U9InByZXNlcnZlIiBwcmVzZXJ2ZUFzcGVjdFJhdGlvPSJub25lIj4NCjxwYXRoIGZpbGwtcnVsZT0iZXZlbm9kZCIgY2xpcC1ydWxlPSJldmVub2RkIiBkPSJNMCwwaDEwMDB2NWMwLDAtMjU1LjY2NC00LTUwMC41MzMtNEMyNDQuNTM5LDEsMCw1LDAsNVYweiIvPg0KPC9zdmc+DQo=" data-reactid="277"/><div style="margin-left:0px;margin-right:0px;" class="ui three column grid" data-reactid="278"><div class="row" data-reactid="279"><div style="margin-left:0px;margin-right:0px;padding-left:0px;padding-right:0px;" class="column" data-reactid="280"><div style="position:relative;top:25px;left:20px;font-family:FuturaTodayBold;font-size:34px;color:#dd9933;" data-reactid="281">“</div><blockquote style="font-family:FuturaTodayDemiBold;font-size:28px;line-height:1.14;text-align:left;color:#333333;display:inline-block;margin:10px 0px 20px 40px;" data-reactid="282"><!-- react-text: 283 -->If you want to win your league, use The Huddle. It’s that simple.<!-- /react-text --><span style="font-family:FuturaTodayBold;font-size:34px;font-weight:bold;line-height:.65;letter-spacing:1.3px;text-align:left;color:#dd9933;" data-reactid="284">”</span></blockquote><p style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:13px;line-height:1.38;text-align:left;color:#666666;font-weight:bold;margin-left:40px;margin-bottom:0px;" data-reactid="285">Paul Friel</p><p style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:13px;line-height:1.38;text-align:left;color:#666666;margin:0px auto 22px 40px;" data-reactid="286">WCOFF $200,000 Champion</p></div><div style="margin-left:0px;margin-right:0px;padding-left:0px;padding-right:0px;" class="column" data-reactid="287"><blockquote style="font-family:FuturaTodayDemiBold;font-size:16px;line-height:1.38;text-align:left;color:#333333;margin:20px 12px 20px 12px;padding-left:12px;padding-right:12px;" class="realTalkBlockQuote" data-reactid="288"><!-- react-text: 289 -->I have been a member of The Huddle for 9 years. I find The Huddle’s information very helpful... The Huddle has the best ‘Ease of Schedule’ ranking system I have ever seen.<!-- /react-text --><span style="font-family:FuturaTodayBold;font-size:34px;font-weight:bold;line-height:.45;letter-spacing:1.3px;text-align:left;color:#dd9933;position:relative;top:6px;" data-reactid="290">”</span></blockquote><p style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:13px;line-height:1.38;text-align:left;color:#666666;font-weight:bold;margin-left:24px;margin-bottom:0px;" data-reactid="291">Kenny Hegmann</p><p style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:13px;line-height:1.38;text-align:left;color:#666666;margin:0px auto 22px 24px;" data-reactid="292">Mr. Fantasy Football $35,000 Champion</p></div><div style="margin-left:0px;margin-right:0px;padding-left:0px;padding-right:0px;" class="column" data-reactid="293"><blockquote style="font-family:FuturaTodayDemiBold;font-size:16px;line-height:1.38;text-align:left;color:#333333;margin:20px 12px 20px 12px;padding-left:12px;padding-right:12px;" class="realTalkBlockQuote" data-reactid="294"><!-- react-text: 295 -->I’ve been a Huddle member for two years… This year we took everything: points, record, ranking, $$$$$, and the championship! Your timely insights helped us draft<!-- /react-text --><!-- react-text: 296 --> <!-- /react-text --><!-- react-text: 297 -->and maintain the best team from top to bottom throughout the entire season. Thanks a million and see you next season.<!-- /react-text --><span style="font-family:FuturaTodayBold;font-size:34px;font-weight:bold;line-height:.45;letter-spacing:1.3px;text-align:left;color:#dd9933;position:relative;top:6px;" data-reactid="298">”</span></blockquote><p style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:13px;line-height:1.38;text-align:left;color:#666666;font-weight:bold;margin-left:24px;margin-bottom:0px;" data-reactid="299">Jerry Mitchell</p><p style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:13px;line-height:1.38;text-align:left;color:#666666;margin:0px auto 22px 24px;" data-reactid="300"></p></div></div></div><div style="height:60px;border:0px;margin:0px 0px;background-color:#dd9933;line-height:normal;display:flex;flex-direction:row;justify-content:center;align-items:center;padding:0px;" class="ui basic center aligned segment" data-reactid="301"><span data-reactid="302"><img class="ui inline image DesktopRealTalk-styles__keyIcon--Ybivl" src="data:image/svg+xml;base64,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" data-reactid="303"/><a href="/subscribe" data-reactid="304"><span class="DesktopRealTalk-styles__fullAccessLabelText--1-Wmp" data-reactid="305">Ready to start winning?</span></a><a href="/subscribe" data-reactid="306"><button class="ui button DesktopRealTalk-styles__fullAccessButton--U7XdL" role="button" data-reactid="307"><!-- react-text: 308 -->FULL ACCESS <!-- /react-text --></button></a></span></div></div><div style="width:100%;background:#333333;margin:0px;padding:20px;" class="ui basic segment" data-reactid="309"><div class="ui grid" data-reactid="310"><div class="row" data-reactid="311"><div class="eleven wide column" data-reactid="312"><div class="desktopFooter__footerLeftLabel--5QRRc" data-reactid="313"><span class="desktopFooter__footerLeftLabelText--39ZF4" data-reactid="314"><!-- react-text: 315 -->Don<!-- /react-text --><!-- react-text: 316 -->’<!-- /react-text --><!-- react-text: 317 -->t miss a thing<!-- /react-text --></span><a target="_blank" class="ui inline image desktopFooter__icon--4BAc9" href="https://www.facebook.com/thehuddle" data-reactid="318"><img src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIyNCIgaGVpZ2h0PSIyNCIgdmlld0JveD0iMCAwIDI0IDI0Ij4KICAgIDxwYXRoIGZpbGw9IiNkZDk5MzMiIGZpbGwtcnVsZT0iZXZlbm9kZCIgZD0iTTIyLjY2NiAwSDEuMzI0Qy41OTMgMCAwIC41OTMgMCAxLjMyNHYyMS4zNDJjMCAuNzMyLjU5MyAxLjMyNSAxLjMyNCAxLjMyNWgxMS40OVYxNC43SDkuNjg4di0zLjYyMmgzLjEyNlY4LjQxYzAtMy4wOTggMS44OTMtNC43ODYgNC42NTctNC43ODYgMS4zMjQgMCAyLjQ2Mi4wOTkgMi43OTQuMTQzdjMuMjM4bC0xLjkxOC4wMDFjLTEuNTAzIDAtMS43OTQuNzE1LTEuNzk0IDEuNzYzdjIuMzExaDMuNTg1bC0uNDY3IDMuNjIxaC0zLjExOHY5LjI5aDYuMTEzYy43MzEgMCAxLjMyNC0uNTkyIDEuMzI0LTEuMzI0VjEuMzI0QzIzLjk5LjU5MyAyMy4zOTcgMCAyMi42NjYgMCIvPgo8L3N2Zz4K" data-reactid="319"/></a><a target="_blank" class="ui inline image desktopFooter__icon--4BAc9" href="https://www.twitter.com/TheHuddle" data-reactid="320"><img src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIyNCIgaGVpZ2h0PSIyMCIgdmlld0JveD0iMCAwIDI0IDIwIj4KICAgIDxwYXRoIGZpbGw9IiNkZDk5MzMiIGZpbGwtcnVsZT0iZXZlbm9kZCIgZD0iTTI0IDIuMzA5YTkuODQzIDkuODQzIDAgMCAxLTIuODI4Ljc3NUE0Ljk0IDQuOTQgMCAwIDAgMjMuMzM3LjM2YTkuODYgOS44NiAwIDAgMS0zLjEyNyAxLjE5NSA0LjkyNCA0LjkyNCAwIDAgMC04LjM5IDQuNDkxQTEzLjk3OSAxMy45NzkgMCAwIDEgMS42Ny45YTQuOSA0LjkgMCAwIDAtLjY2NiAyLjQ3NmMwIDEuNzA4Ljg3IDMuMjE1IDIuMTkgNC4wOThhNC45MDQgNC45MDQgMCAwIDEtMi4yMy0uNjE2di4wNjJhNC45MjcgNC45MjcgMCAwIDAgMy45NSA0LjgyOCA0LjkzNCA0LjkzNCAwIDAgMS0yLjIyNC4wODUgNC45MjkgNC45MjkgMCAwIDAgNC42IDMuNDE5IDkuODc5IDkuODc5IDAgMCAxLTYuMTE1IDIuMTA4Yy0uMzk4IDAtLjc5LS4wMjQtMS4xNzUtLjA3YTEzLjkzNiAxMy45MzYgMCAwIDAgNy41NDggMi4yMTNjOS4wNTcgMCAxNC4wMS03LjUwMyAxNC4wMS0xNC4wMSAwLS4yMTMtLjAwNi0uNDI1LS4wMTUtLjYzNkExMC4wMDIgMTAuMDAyIDAgMCAwIDI0IDIuMzA4Ii8+Cjwvc3ZnPgo=" data-reactid="321"/></a><a target="_blank" class="ui inline image desktopFooter__icon--4BAc9" href="http://thehuddle.com/category/podcast/" data-reactid="322"><img src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNiIgaGVpZ2h0PSIyNCIgdmlld0JveD0iMCAwIDE2IDI0Ij4KICAgIDxwYXRoIGZpbGw9IiNEOTMiIGZpbGwtcnVsZT0iZXZlbm9kZCIgZD0iTTE0IDZjMCA3LTIuMSAxMC02IDEwLTMuOTEgMC02LTItNi0xMEgwYzAgOSAzIDEyIDcgMTJ2NC4wMWMtMy4zOS4wNy02IC40OS02IC45OSAwIC41NSAzLjEzIDEgNyAxczctLjQ1IDctMWMwLS41LTIuNjEtLjkyLTYtLjk5VjE4YzMgMCA3LTMgNy0xMmgtMnptLTYgOGMyLjQ5IDAgNC0xLjk3IDQtNUg4VjhoNFY3SDhWNmg0VjVIOFY0aDMuOTRDMTEuNjMgMS41NSAxMC4yIDAgOCAwIDUuNTEgMCA0IDEuOTcgNCA1djRjMCAzLjAzIDEuNTEgNSA0IDV6Ii8+Cjwvc3ZnPgo=" data-reactid="323"/></a></div><div style="margin-left:0px;" class="ui grid" data-reactid="324"><div class="row" data-reactid="325"><div style="padding:0 20px 0 0px;margin-left:0px;" class="four wide column" data-reactid="326"><div style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:14px;margin-bottom:10px;line-height:1.43;letter-spacing:0.4px;text-align:left;color:#cccccc;" data-reactid="327"><a href="https://thehuddle.com/2021-fantasy-football-draft-guide/" style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:14px;margin-bottom:10px;line-height:1.43;letter-spacing:0.4px;text-align:left;color:#cccccc;" data-reactid="328">Preseason Draft Kit</a></div><div style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:14px;margin-bottom:10px;line-height:1.43;letter-spacing:0.4px;text-align:left;color:#cccccc;" data-reactid="329"><a href="/playerLanding" style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:14px;margin-bottom:10px;line-height:1.43;letter-spacing:0.4px;text-align:left;color:#cccccc;" data-reactid="330">Players</a></div><div style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:14px;margin-bottom:10px;line-height:1.43;letter-spacing:0.4px;text-align:left;color:#cccccc;" data-reactid="331"><a href="http://thehuddle.com/fantasy-football-statistics/" style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:14px;margin-bottom:10px;line-height:1.43;letter-spacing:0.4px;text-align:left;color:#cccccc;" data-reactid="332">Statistics</a></div></div><div style="padding:0 20px 0 0px;margin-left:0px;" class="four wide column" data-reactid="333"><div style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:14px;margin-bottom:10px;line-height:1.43;letter-spacing:0.4px;text-align:left;color:#cccccc;" data-reactid="334"><a href="https://tools.thehuddle.com/nfl-depth-charts" style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:14px;margin-bottom:10px;line-height:1.43;letter-spacing:0.4px;text-align:left;color:#cccccc;" data-reactid="335">NFL Depth Charts</a></div><div style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:14px;margin-bottom:10px;line-height:1.43;letter-spacing:0.4px;text-align:left;color:#cccccc;" data-reactid="336"><a href="https://tools.thehuddle.com/teams" style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:14px;margin-bottom:10px;line-height:1.43;letter-spacing:0.4px;text-align:left;color:#cccccc;" data-reactid="337">NFL Teams</a></div><div style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:14px;margin-bottom:10px;line-height:1.43;letter-spacing:0.4px;text-align:left;color:#cccccc;" data-reactid="338"><a href="http://forums.thehuddle.com" style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:14px;margin-bottom:10px;line-height:1.43;letter-spacing:0.4px;text-align:left;color:#cccccc;" data-reactid="339">Forums</a></div></div><div style="padding:0 20px 0 0px;margin-left:0px;" class="four wide column" data-reactid="340"><div style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:14px;margin-bottom:10px;line-height:1.43;letter-spacing:0.4px;text-align:left;color:#cccccc;" data-reactid="341"><a href="https://tools.thehuddle.com/subscribe" style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:14px;margin-bottom:10px;line-height:1.43;letter-spacing:0.4px;text-align:left;color:#cccccc;" data-reactid="342">Join the Huddle</a></div><div style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:14px;margin-bottom:10px;line-height:1.43;letter-spacing:0.4px;text-align:left;color:#cccccc;" data-reactid="343"><a href="http://thehuddle.com/about/" style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:14px;margin-bottom:10px;line-height:1.43;letter-spacing:0.4px;text-align:left;color:#cccccc;" data-reactid="344">About Us</a></div></div><div style="padding:0 20px 0 0px;margin-left:0px;" class="four wide column" data-reactid="345"><div style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:14px;margin-bottom:10px;line-height:1.43;letter-spacing:0.4px;text-align:left;color:#cccccc;" data-reactid="346"><a href="http://thehuddle.com/help" style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:14px;margin-bottom:10px;line-height:1.43;letter-spacing:0.4px;text-align:left;color:#cccccc;" data-reactid="347">Help</a></div><div style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:14px;margin-bottom:10px;line-height:1.43;letter-spacing:0.4px;text-align:left;color:#cccccc;" data-reactid="348"><a href="http://thehuddle.com/contact-us" style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:14px;margin-bottom:10px;line-height:1.43;letter-spacing:0.4px;text-align:left;color:#cccccc;" data-reactid="349">Contact Us</a></div></div></div></div></div><div class="five wide column" data-reactid="350"><div class="desktopFooter__footerLeftLabel--5QRRc" data-reactid="351"><span class="desktopFooter__footerLeftLabelText--39ZF4" data-reactid="352">Newsletter</span></div><form data-reactid="353"><div class="ui transparent input desktopFooter__enterEmailInput--11Fq7" data-reactid="354"><input type="text" placeholder="Enter your email address" value="" data-reactid="355"/></div><button class="ui disabled button desktopFooter__signUpButton--10FIv" disabled="" role="button" tabindex="-1" data-reactid="356"><!-- react-text: 357 -->SIGN UP<!-- /react-text --></button></form><p class="desktopFooter__footerBlurbText--3Fvjm" data-reactid="358">Sign up for our free newsletter and get great tips and updates.</p></div></div><div class="eleven wide column" data-reactid="359"><div class="sixteen wide column" data-reactid="360"><p style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:12px;margin-bottom:10px;line-height:1.43;letter-spacing:0.4px;text-align:left;color:#cccccc;" data-reactid="361">The Huddle is a member of the Pro Football Writers of America, Fantasy Sports Trade Association and Fantasy Sports Writers Association.</p><p style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:12px;margin-bottom:10px;line-height:1.43;letter-spacing:0.4px;text-align:left;color:#cccccc;" data-reactid="362"><!-- react-text: 363 -->Use of this website constitutes acceptance of its <!-- /react-text --><a style="color:#cccccc;text-decoration:underline;" href="https://static.usatoday.com/privacy/" target="_blank" data-reactid="364">Privacy Notice</a><!-- react-text: 365 --> and <!-- /react-text --><a style="color:#cccccc;text-decoration:underline;" href="https://static.usatoday.com/terms/" target="_blank" data-reactid="366">Terms of Use</a><!-- react-text: 367 -->.<!-- /react-text --><!-- react-text: 368 --> <!-- /react-text --></p><p style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:12px;margin-bottom:10px;line-height:1.43;letter-spacing:0.4px;text-align:left;color:#cccccc;" data-reactid="369"><!-- react-text: 370 -->© <!-- /react-text --><!-- react-text: 371 -->2022<!-- /react-text --><!-- react-text: 372 --> THEHUDDLE.COM<!-- /react-text --></p><p style="font-family:&#x27;Helvetica Neue&#x27;, Helvetica, Arial, &#x27;Lucida Grande&#x27;, sans-serif;font-size:12px;margin-bottom:10px;line-height:1.43;letter-spacing:0.4px;text-align:left;color:#cccccc;" data-reactid="373">Part of USA TODAY Sports Digital Properties</p></div></div></div></div></div></div></div>
          <script type="text/javascript" charSet="UTF-8">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</script>

          <script type='text/javascript' src='/static/bootstrap.3b284641eacd3948d4b7.js' defer></script>
<script type='text/javascript' src='/static/js/Layout.56479819e7d6428c0794.js' defer></script>
<script type='text/javascript' src='/static/js/News.e812876fb10e047abade.js' defer></script>
<script type='text/javascript' src='/static/js/main.778d59eb98abe39a5699.js' defer></script>
          <script type='text/javascript'>window.__CSS_CHUNKS__= {"Layout":"/static/stylesheets/Layout.1c18b151097dde2a505275d23dd1c719.css","CheatSheets":"/static/stylesheets/CheatSheets.20b2e598b5fb9e86c579fa75bb63df97.css","Team":"/static/stylesheets/Team.fe14f1d8c438194862cd5c5ce3f1e909.css","News":"/static/stylesheets/News.fe9d51a926ed47c53c47d3dc4837a638.css","Player":"/static/stylesheets/Player.3ad7240ad2e76746339f88d8a0eb0e76.css","HuddleSearch":"/static/stylesheets/HuddleSearch.01bc75d3d75cc32504c24287dc27135e.css","LearnMore":"/static/stylesheets/LearnMore.b565dab0748386a83df48413240aba17.css","DepthCharts":"/static/stylesheets/DepthCharts.bf1e3eb22bec95e914102120fedd613e.css","WeeklyStats":"/static/stylesheets/WeeklyStats.e9138cda223a86b4941a36c4da6aac0a.css","StartBench":"/static/stylesheets/StartBench.3cf8530f0e8cf7d93a42f34cb7882bdd.css","PlayerProjections":"/static/stylesheets/PlayerProjections.a97dd82d2411cfd6b15f1d468dfb5be2.css","PrintProjections":"/static/stylesheets/PrintProjections.f7c913e776187dc331008792963b1702.css","BoxScores":"/static/stylesheets/BoxScores.ebcfe5471b145689cfd8b072dc2bb21c.css","Dynasty":"/static/stylesheets/Dynasty.9f6fd9251244b907e96fe5585a91d657.css","Auction12":"/static/stylesheets/Auction12.a9655b6fd56b5b702fb2557ffa39800e.css","Auction10":"/static/stylesheets/Auction10.70be6123fe81d56b8c13264004b8fd1f.css","TeamPositionRankings":"/static/stylesheets/TeamPositionRankings.1cb58c524cf094811b53be58582dddd8.css","Season":"/static/stylesheets/Season.0f5c9a73ef55377df00a30cc16e7ba76.css","Top200QB":"/static/stylesheets/Top200QB.7d863520ae6ca1987e915d35cf8f1d38.css","Top200PPR":"/static/stylesheets/Top200PPR.cda60f707b878026f08ab2349cd4535a.css","Top200":"/static/stylesheets/Top200.f27caef5323edb12149c62bf918e6a7a.css","FiltersHeader":"/static/stylesheets/FiltersHeader.29d6a8484736572fe0a644a39232008d.css","Print":"/static/stylesheets/Print.49a6680cad31cd8d338f8873fc2c97dd.css","PlayerTracking":"/static/stylesheets/PlayerTracking.a2d3bbfc46a2328343309e1a1adeea2d.css","TeamsLanding":"/static/stylesheets/TeamsLanding.852bc1fb08e7f24fc9f186ba1147f871.css","Custom":"/static/stylesheets/Custom.960dfea6ed551bb28527b14547f55441.css","Predictions":"/static/stylesheets/Predictions.051b1fb0bd0b601d099565d84642ec13.css","MatchupAnalysis":"/static/stylesheets/MatchupAnalysis.eda812cc6aeaaebc9d09abea206b335c.css","TeamPRM":"/static/stylesheets/TeamPRM.043809ebd1d4ab71639f73f00f0734e7.css","StrengthOfSchedule":"/static/stylesheets/StrengthOfSchedule.248d07288fd00bef5469646bf9c5a878.css","ConnectedEmailPreferences":"/static/stylesheets/ConnectedEmailPreferences.eae1452a9dc7c61d44a4e81c42b550df.css","Edit":"/static/stylesheets/Edit.753635a450739ada6525374bce736b14.css","Duplicate":"/static/stylesheets/Duplicate.655d4d1723b6aac955958b03fe6f82d0.css","Details":"/static/stylesheets/Details.b453a303319726f812c46f9cdc9cae0c.css","Create":"/static/stylesheets/Create.a7098299580750e58efaf6920efafcd9.css","AccountInfo":"/static/stylesheets/AccountInfo.37b1740d52798d00605b35d50668133f.css","MyHuddleContainer":"/static/stylesheets/MyHuddleContainer.ae21d94a46dfc9f79798e0221e10b0b5.css","RequestUsername":"/static/stylesheets/RequestUsername.16f037ac0e027da454b66eaa5f4c409c.css","ResetPassword":"/static/stylesheets/ResetPassword.9ed1a95f0fd712d9b98638655004a295.css","RequestPassword":"/static/stylesheets/RequestPassword.c1027dd7136bd4c17daa85885ec71391.css","RequestPassword2":"/static/stylesheets/RequestPassword2.caae391943d33d7847c382cc6755afbf.css","Logout":"/static/stylesheets/Logout.de20339931fe0e95a2fa5b69453e7008.css","Login":"/static/stylesheets/Login.d8907254f0a313607b963b5ee123abf7.css","main":"/static/stylesheets/main.d0ac3f7d409591d7c86912cc98c2f754.css"}</script>
        </body>
      </html>